Tuesday, June 4, 2013

Stable Channel Update

The Stable channel has been updated to 27.0.1453.110 for Windows, Macintosh, Linux and Chrome Frame platforms.

Security fixes and rewards:

Please see the Chromium security page for more information. (Note that the referenced bugs may be kept private until a majority of our users are up to date with the fix.)

This automatic update includes security fixes. We’d like to highlight the following fixes for various reasons (crediting external researchers, issuing rewards, or highlighting particularly interesting issues):

  • [Windows only] [$2000] [243339] High CVE-2013-2854: Bad handle passed to renderer. Credit to Collin Payne.
  • [$500] [242322] Medium CVE-2013-2855: Memory corruption in dev tools API. Credit to “daniel.zulla”.
  • [$1000] [242224] High CVE-2013-2856: Use-after-free in input handling. Credit to miaubiz.
  • [$1000] [240124] High CVE-2013-2857: Use-after-free in image handling. Credit to miaubiz.
  • [$500] [239897] High CVE-2013-2858: Use-after-free in HTML5 Audio. Credit to “cdel921”.
  • [$1500] [237022] High CVE-2013-2859: Cross-origin namespace pollution. Credit to “bobbyholley”.
  • [$1337] [225546] High CVE-2013-2860: Use-after-free with workers accessing database APIs. Credit to Collin Payne.
  • [$1000] [209604] High CVE-2013-2861: Use-after-free with SVG. Credit to miaubiz.
  • [$1000] [161077] High CVE-2013-2862: Memory corruption in Skia GPU handling. Credit to Atte Kettunen of OUSPG.
  • [232633] Critical CVE-2013-2863: Memory corruption in SSL socket handling. Credit to Sebastien Marchand of the Chromium development community.
  • [239134] High CVE-2013-2864: Bad free in PDF viewer. Credit to Mateusz Jurczyk, with contributions by Gynvael Coldwind, both from Google Security Team.

In addition, our ongoing internal security work was as usual responsible for a wide range of fixes:

[246389] High CVE-2013-2865: Various fixes from internal audits, fuzzing and other initiatives.

Full details about what changes are in this build are available in the SVN revision log. Interested in switching release channels? Find out how. If you find a new issue, please let us know by filing a bug.

Karen Grunberg

Google Chrome

6 comments:

Rafael Hilário said...
This comment has been removed by the author.
Rafael Hilário said...

The Google Chrome browser has been excellent over with each new update does not change much in the layout and assign what changes is more housing in the browser else remains the same. I tested Opera 15.0 beta on your version and I can say that Opera is using the same engine Google Chrome is much better than the browser itself. Please Chrome conquer me again, because navigation is slow pages and catching many bugs and the same layout.

Unknown said...

Does this fix the bug where chrome crashes if I detatch a tab, something I heard was related to libdev0 ?

Timothy J. Holloway said...

Is this long list of bug fixes why Chrome OS stable channel hasn't been updated as promised? That almost makes sense except I'm assuming every other platform has an updated version of Chrome except Chrome OS.

It's unfortunate that Google can't really be trusted to do what it says it will, especially without long delays, complications, or downright failing to live up to their own advertising.

www.keyguru.blogspot.in said...

Really great.........
Download Latest version of chrome 27 beta..........
http://keyguru.blogspot.com/2013/06/downloadgooglechrome27.0.1453.110.html

Avery Pope said...

hi Google support. i am having trouble with my sound since this update i have a windows 7 system with a JBL sound built in to my laptop. i tried to watch a few youtube videos this past week but with no luck the sound was not working. so i thought it was a problem with just youtube. later that day i went on multiple sites to see if the video/sound would work but the same problem occurs no sound. well then i thought it could have been my computer or adobe flash player so i checked some music formats on my laptop and listen to some songs they worked fine. i watched a movie that worked fine. so then i thought well it could probably be a internet problem so i used another internet browser (IE,aurora ext.) and they had no sound issues all worked fine (except chrome). i believe the problem lies with the automatic adobe update. which is built into chrome. can you guys please get back to me on this. it would be great if you can find a solution i have looked all over the internet but havent found a 100% fix. i very much prefer Google chrome as a browser.

thank you