Thursday, June 28, 2012

Dev Channel Update

The Dev channel has been updated to 21.0.1180.15 for  Windows, Mac, Linux, and Chrome Frame platforms

This version fixes a small sync problem (Issue: 134715and contains a fix for Mac hardware with the Intel HD 4000 graphics chip (e.g. the new Macbook Airs), in order to prevent a resource leak which is causing a kernel panic on that hardware. This is a temporary change while we work on fixing the root cause of the issue.

More details about additional changes are available in the svn log of all revisions.  You can find out about getting on the Dev channel here: http://dev.chromium.org/getting-involved/dev-channel. If you find new issues, please let us know by filing a bug at http://code.google.com/p/chromium/issues/entry

Karen Grunberg
Google Chrome

20 comments:

Juan Sebastian Monroy Nieto said...

Please add the "smart zoom" thingy to chrome in the mac :D

SynFlag said...

Please, fix the bug of 19.x and 20:

When i switch full screen mode, on Linux, watching youtube, Chrome no return to normal mode, press F11, etc, and not.... only killall chrome.

methanhydrat said...

no offline installer? :sadpanda:

Aman Hayer said...

Will this also fix the same problem on Macbook Pros as well?

HurpDurp said...

For the last several versions, captchas are always wrong unless I request a new one before attempting it.

Yes, I had to do it posting here too.

Jazzer said...

@methanhydrat and @Karen Grunberg

Using the normal Procedure to download the latest Build 21.0.1180.15, i.e.
"http://dl.google.com/chrome/install/1180.15/chrome_installer.exe"

But this time we get a very *strange* Result:

1. We do NOT get a _normal_
Installer like
previous "chrome_installer.exe"
with file version 21.0.1180.11
and size 28.7 MB
(30,174,632 bytes)

2. Instead we get the _strange_
Installer
with file version 1.3.21.111
and size 722 KB
(739,856 bytes) -

These 2 non-normal properties
did NEVER occur before and
i installed my first Chrome
(beta) with Version "0.3.154.9"
actually on November 1, 2008 !!

3. Nevertheless, after
clicking "About Google Chrome"
my Chrome Developer Version
was as usual updated
from "21.0.1180.11"
to "21.0.1180.15" !!

But i did not dare to try a
_manual_ install using the
small "chrome_installer.exe"
(Number 2 above)...

Karen, please provide further
clarification about how this
update works!

Victor said...

That resource leak isn't just on latest Macs with the Intel HD chip, it's also on my iMac 7,2 with Chrome.

As one of the potential indicators of the problem, playing a Flash video exacerbates the problem. By looking at RAM memory, Flash overwhelms the system. Even after closing the Flash video windows, Flash still overwhelms the RAM.

Flash is lousy but Chrome makes it worse.

Ken Zinnato said...

Direct download is no longer
"http://dl.google.com/chrome/install/1180.15/chrome_installer.exe"

but now
"http://dl.google.com/chrome/win/21.0.1180.15_chrome_installer.exe"

(obviously, substitute your operating system)

Jazzer said...

@Ken Zinnato

Hello Ken,
Thank you very, vary much!

Your Answer solved _all_ my questions
(see my post a litte above)...

The new download of dev version
21.0.1180.15 now has a reasonable
size of 28.7 MB (30,162,856 bytes).

Also, the new scheme for manually download Chrome's Installer files
has a much better logic to grasp!

Muhammad Ridha Ar-Rasyid said...

Reasource memory up to 400MB... it's too high...

Unknown said...

I see a smattering of pages scaled down and opened in an area much smaller than the Chrome window when I restart Chrome. So far, this only happens on AnandTech and Ars Technica.

Refreshing the page doesn't work, and I can browse through the content in this little webpage area.

If I hit the home button, the page suddenly becomes full-window size. I can then go back and the previous URL will be rendered at full-window size. All is well then.

If I right click on the gray area outside the rendered content, there is no RMB menu. Inside the content area, RMB > Inspect Element makes the same URL render full-window, so I'm not able to glean anything from using Inspect Element.

This first happened to me with the previous dev channel release. Win8 x64 CP.

Apicio said...

Too much RAM, and flash doesn't work good (just see SimCity on Facebook)

O said...

Lag on Youtube's HD 1080p videos. Performance has been decreasing by alot since 21.0.1171.0 Dev for video rendering especially on Youtube's 1080p. Youtube Frame rate dropped increases.

O said...

Reverted back to 21.0.1171.0 Dev for Windows 7 Ultimate with FiOS connection. This is the best version along the road to the latest dev now.

Jeerapot Buachan said...
This comment has been removed by the author.
Jeerapot Buachan said...
This comment has been removed by the author.
Jeerapot Buachan said...
This comment has been removed by the author.
Jeerapot Buachan said...
This comment has been removed by the author.
Jeerapot Buachan said...

Please fix about Imported(bookmark) that should to use Home & End button on keyboard to quickly.

Emannxx said...

Please fix smooth scrolling!