Monday, September 26, 2011

Dev Channel Update


The Dev channel has been updated to 16.0.891.0 for Windows, Mac, Linux, and Chrome Frame.
  • Linux: Enabled Native Client for 32-bit Linux and also addresses a performance issue for Native Client on Intel Atom CPUs. [Issue: 92964], [nativeclient: 480]
  • Linux: Fixed fetching proxy settings on Gnome 3 systems when glib2-dev package is not installed. [Issue: 91744]
  • All: Fixed many known stability issues.
Full details about what changes are in this build are available in the SVN revision log.  Interested in switching to the Beta or Stable channels?  Find out how.  If you find a new issue, please let us know by filing a bug.

Dharani Govindan
Google Chrome

45 comments:

Alen said...

Keep up the good work!!

Josep Bel said...

the same font and scroll issues :-(

REO said...

Windows Vista/32 bit

Not sure if all font issues were corrected.

Twitter.com site still pretty FUBAR.

Improving somewhat.

Thanks for the quick update responses.

Alejandro Angel said...

Problems in twiter.com remaining

Jerry H said...

Still waiting for a fix for gtalk video chat...

Andrey Mironov said...

Having problem with fonts too. Windows 7 x64.

kick95 said...

Got Chinese Font problem and Twitter problem still exists!!

aziz said...

fonts in google reader sux too

Sascha Picchiantano said...

Great. The update killed my tab history. After restart, all my open and pinned tabs where closed and I was presented with an empty window. Who's butt can I kick for that?

grachev84 said...

Same issue with twitter and youtube progressbar on videos

Alex said...

As above, Twitter is still fubar.

tcloer said...

Still massive font rendering issues (even on Google's own properties) and scrolling problems on twitter.com.

Win 7 Ultimate 32-Bit, Mac seems to be fine.

Slivver said...

@Sascha Picchiantano, you can't kick anyone's butt as you are using the DEV channel.

If you don't wish to run the risk of having things crash, render incorrectly, perform poorly and lose data then I would suggest that you use the Stable release instead.

Chromana said...

Had a strange bug on startup. This is exactly what I did:
1. My previous session tabs loaded fine.
2. I opened a youtube tab and started to play a video.
3. I opened a twitter tab and got the "Something's gone wrong with this tab" message (with the dark background, although BG colour might be from my theme).
Then any sites in tabs I opened got that same message, even if I closed and reopened any tabs that were working fine on start-up.

Had to restart Chrome to fix.

Chromana said...

^ Should have mentioned:
Windows 7, 64-bit.
Also Twitter + fonts are still busted, here.

rob said...

Since Google Canary 16.0.880 Chrome has been crashing constantly.
Here is what happens.I open the browser and open a web page .After opening 6 or 7 new pages/tabs the pages begin to open slower and slower until they do not open at all and I get the kill pages ? dialogue.Chrome then ceases to function.
I´m on windows xp sp3

rob said...

Latest Chrome 16.0.891.0 Beta.Same story.Open a few pages and Chrome grinds to a halt.The browser has become unusable for me on windows XP.My son has windows 7 and I think it is working ok there.
But for me I´m migrating to Aurora till this is fixed

§{真}§ said...

http://tinyurl.com/3d3c8n9

the problem of chinese can fix Temporarily by this...

Prezom said...

There's a big problem with Chinese font. please fix it , I really like chrome and I don't want to use other browser as alternative.

khan said...

google chrome in my blood i love chrome updates

but i didn't install new because of removing chrome:flag compact navigation bar so please add it its
a humble request

arthatek said...

16.0.891.0 dev OS X 10.5.8 all fonts unreadable, just little dots everywhere. all sites. Chrome down :(

Anthony56 said...

v 16.0.893.0 and Twitter* still slow. More than one week !
Is Google boycotting Twitter for Google+ ?

*Twitter is the only website i actually have a problem

REO said...

Font rendering tip:

Try turning off any 'flags' that have to do with rendering and your display 'may' improve - 'a little'. There still are problems, but it does get better. Twitter.com is still FUBAR in so many ways with latest version of Dev Chrome.

Win\Vista\32bit

js94tj said...

Chrome still has major keyboard text shortcut issues.

Gruntfuggly said...

Can we please have the smaller pinned tabs back? I don't understand why they were made bigger by bug 100538?

Michel Bohms said...

crashing when checking for updates on w97/64bit

Dave said...

font smoothing terrible on lion. looks like a linux install that has no windows font pack installed.

Handycam said...

Works fine on Lion, except Twitter.com will not scroll.

DopedAngel said...

Auto Translate or right click translate is not working for me since quite a few development versions

http://www.the-ebook.org/ is detected as russian but not translates.

Rosaita said...

Get horrible bug in Chinese displaying, totally unreadable.

Matias said...

flash problem slow pages

Pranay Pandya said...

fonts are fubar

@danwet said...

Yes, font redering problems too! #lion

δΊŒη‹— said...

I confirm the Chinese characters rendering problem!
Next time test with stuff other than A-Z as well please.

Jay Levitt said...

Hooray! This morning's 16.0.891.*1* on Mac fixes the worst of the font problems - no subpixel anti-aliasing or subpixel positioning. See http://code.google.com/p/chromium/issues/detail?id=97829) and http://code.google.com/p/chromium/issues/detail?id=98165.

Thanks for the quick fix, guys.. 16 was unusable, and I need it because it fixes an hourly crasher for me.

msi2 said...

Ok, it seems the cleartype issue has been fixed, but now the font is too bold and a bit blurry imo... :(. I'm comparing that to Chrome 14.

WinXP SP3.

Enterpr1se™ said...

Any new update information?

H.F.Kais said...

twitter and google image search scroll problem is not soulted.

Unknown said...

trandition chinese font issue like this

http://i.imgur.com/0EbSe.jpg

Roy-Tse said...

alot of broken texts on certain websites, please fix

brant said...

The font rendering issues have been fixed in the 16.0.896.0 Canary build.

I am not sure when this will make its way to DEV however.

REO said...

Thanks @brant - 16.0.896.0 Canary build is beautiful!

Hope it arrives on the Dev channel soon.

Win Vista/32 bit

Alex said...

Twitter issues still exist in 16.0.896.0 though!

Kevin Hua said...

please fix the twitter and cjk letter issues

CyberMew said...

Definitely some corruption issues. Been running it for a few days now and display of text in forum textboxes are rubbish. I am surprised it didn't crashed yet.