Tuesday, August 23, 2011

Beta Channel Update

The Beta channel has been updated to 14.0.835.109 for Windows, Mac, Linux, and Chrome Frame.  This release contains fixes for a number of stability issues along with other bugs.  Full details about what changes are in this build are available in the SVN revision log.  Interested in switching to the Beta channel?  Find out how.  If you find a new issue, please let us know by filing a bug.

Jason Kersey
Google Chrome

14 comments:

FREEWILLY said...

Great, thanks. All back to normal. After updating Chrome to M14, adblock to 1.1.4 and my graphics drivers, Chrome is straight flying with 25 pinned tabs! Loaded all of them on a cold start w/ clear cache in maybe 3 seconds.

P.S. can't wait for new extension API to allow true adblocking! As well as the new extension UI that lets us know when extensions are updated, in the process of updating, etc.

Looking good Chrome team!

-B

www.novedoso.tk said...

I hope that fix the performance problem in 64-bit version of ubuntu linux

(see the report 93334 in chrome: http://code.google.com/p/chromium/issues/detail?id=93334&can=4&colspec=ID%20Stars%20Pri%20Area%20Feature%20Type%20Status%20Summary%20Modified%20Owner%20Mstone%20OS

a said...

Waiting fir chrome to support ajax in vbulletin forums

MakHooi said...

I do not know what happened to this update. But I am getting a total of 5 crashes in about 5 minutes. LOL. Hope this can be fixed asap.

http://code.google.com/p/chromium/issues/detail?id=93986
http://code.google.com/p/chromium/issues/detail?id=93987
http://code.google.com/p/chromium/issues/detail?id=93988
http://code.google.com/p/chromium/issues/detail?id=93989
http://code.google.com/p/chromium/issues/detail?id=93990

William said...

Everything is perfect over here. With the exception of sync not working. The circular loading icon just keeps on spinning. Been that way for a few versions, plz fix!

Dewi said...

This update did *not* go well here. Session & all bookmarks gone, all extensions/apps broken (but still listed).

I tried reinstalling from the landing page, which got sync working & restored my bookmarks, but extensions are still broken and About says "Update server not available (error: 1)" so stuff is still pretty broken.

FREEWILLY said...

Oh, shockwave flash keeps crashing when I close out an ebay page. Happened 5 times already. Did Adobe release a new version of stable flash today anyway...?

Dewi said...

After deleting entire profile, everything looks okay now with this build.

Marco said...

My profile icon (upper left corner) dissapeared after upgrading to this version (14.0.835.109 beta). I desinstall completely and reinstall but profile icon didn't come back.
What can I do?

Kevin Lauriault said...

My profile icon disappeared also and the multiple profile flag is missing in about:flags. My wife and I use this feature a lot. Any fixes?

raducu83 said...

@ Kevin Lauriault : From what I have seen the profile feature had allot of stability issues so it was disabled for M14 but will be present in M15

Sue and Jay said...

My shockwave flash has started crashing. Does anyone know what I should do?

FREEWILLY said...

^same here. Wait until next beta release I guess, should be soon. Hopefully this is fixed along with sync.

Unknown said...

I'm now on the Beta channel 14.0.835.109 which shows Flash 10.3.138.5---->however the browser is much more responsive in all aspects then the Stable channel 13.0.782.215...Just reviewed this on Chrome Releases blog:
I have disabled built-in Chrome Flash 10.3.183.5 plugin and then downloaded the Adobe 10.3.183.7. exe (plugin)....so 14.0.835.109 is now utilizing system flash...(Have not disabled Chrome Flash hardware acceleration)....all YouTube videos and other heavy flash sites (thus far...lol) running smoothly..
No extensions, and no crashes, freezes yet...