Thursday, April 28, 2011

Beta and Stable Channel Update

The Beta and Stable channels have been updated to 11.0.696.60 for the Windows platform

The following bug was fixed:
  • REGRESSION: Windows painting issue while switching Chrome 11 window with overlapped app. (Issue 74604).
If you find new issues, please let us know by filing a bug.

Want to change to another Chrome release channel? Find out how.

Karen Grunberg
Google Chrome

18 comments:

Groovy™ said...

The version info still shows "11.0.696.60 unknown". What does this mean "unknown"?

Karen said...

just a cosmetic issue. we wil fix it. thank you so much!!

Mesca Vlad said...

@Karen - in benchmark chrome 11.0.696.60 si slower then 11.0.696.57

David Newkirk said...

The control to restart Chrome after updating is labeled with the word "Relaunch" instead of "Restart." That's dev jargon; launching is for missiles. I strongly recommend returning to and staying with the usages "Start" and "Restart" instead of drifting back/inward to "Launch" and "Relaunch."

K. A . LaBarre - Owner/Director said...

Karen, are you aware that 11.0.696.57 crashes on launch in latest OSX?

Process: Google Chrome [402]
Path: /Applications/Google Chrome.app/Contents/MacOS/Google Chrome
Identifier: com.google.Chrome
Version: 11.0.696.57 (696.57)
Code Type: X86 (Native)
Parent Process: launchd [140]

Date/Time: 2011-04-29 13:03:56.344 -0500
OS Version: Mac OS X 10.6.7 (10J869)
Report Version: 6

Interval Since Last Report: 493367 sec
Crashes Since Last Report: 681
Per-App Interval Since Last Report: 20 sec
Per-App Crashes Since Last Report: 18
Anonymous UUID: 2257E4B8-2EB1-4AD5-94E8-A3F3D96B3E3A

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000007fffb370
Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread

Karen said...

K. A . LaBarre - looking into it right now. have you already filed a bug, if not would you mind filing one? thank u so so much!

Karen said...

K. A . LaBarre = we tried reproducing it but we can't. if you file a bug we can work with you to see if we can pinpoint where the problem occurs. Here's the link to file a bug:

http://code.google.com/p/chromium/issues/entry

thank you so much in advance!
Karen

Gabi said...

Does Google Chrome 11 has hardware acceleration activated by default ?

coy said...

just to report some minor issue encountered... still old icon on desktop shortcut, new icon already at taskbar. BTW thanks, I saw it already filed on the "issue entry". :)

windows xp sp3

béatrix idéfix said...

After the atualization, all my apps and extensions disappeared. I lost many things... And when opening a new tab there isn't the Icon for the app store. Terrible.

Rotilho said...
This comment has been removed by the author.
Rotilho said...
This comment has been removed by the author.
Rotilho said...

After a certain time of use when trying to write a new page Chrome stops work and I have to force its close on my Mac (10.6.7)

samg said...

Hi Karen: Other issues related to this release (fw warnings, installation path conventions, etc) are being discussed in Chrome Support Forum here if you're interested. PS - I adore Chrome. Plus, any company who employs Vint Cerf wins :o) -samg

sibin said...

when i try to import bookmarks from firefox 4 right after i install chrome 11 it doesn't work. it works with IE 9 though.

oh and please keep this style you used, i mean the colors and the font style and overall look of the chrome website
http://www.google.com/chrome/intl/en/make/download-b.html

it looks nice

get rid of this
http://www.google.com/chrome/intl/en/landing_chrome.html?hl=en

it looks old and outdated

Tobias said...

Hi Karen.
Business Chrome (msi file) is still on 11.0.696.57 and not on 11.0.696.60.

Please correct this!
Thank you!

original_mirre said...

Hi

Since the update to verion "11.0.696.60 unknown" from Chrome 10, Chrome has become EXTREMELY slow, totally unusable... I don't know what it does, but when I stream music while surfing, the streaming gets interrupted... so maybe Chrome does something which uses/needs extremely much bandwidth. Using a 10/10 MBit line, Win XP with SP 3.

With regards
Emir

didact1969 said...

.60 significantly slower than .57. Windows XP. Tried to downgrade but seems almost impossible if you use googlepack, i.e. global install.