Friday, March 11, 2011

Stable and Beta Channel Updates

The Chrome Stable and Beta channels have been updated to 10.0.648.133 for Windows, Mac, Linux and Chrome Frame. This release fixes the following security issue:

Security fixes and rewards:
Please see the Chromium security page for more detail. Note that the referenced bugs may be kept private until a majority of our users are up to date with the fix.
  • [$1337] CVE-2011-1290 [75712] High Memory corruption in style handling. Credit to Vincenzo Iozzo, Ralf Philipp Weinmann and Willem Pinckaers reported through ZDI (ZDI-CAN-1167).
If you find new issues, please let us know by filing a bug. Want to change to another Chrome release channel? Find out how.

Jason Kersey
Google Chrome

16 comments:

William said...

I've been wondering for a while now if the beta channel is behind when a new stable milestone comes out but I guess this update answers my question. All of the security updates in the stable version of Chrome 10 were already fixed in the beta channel correct?

Thanks for the update! :]

jja80 said...

The linux repository is missing. I get a 404 Not Found when trying to DL through http://www.google.com/chrome/eula.html as well as through http://dl.google.com/linux/chrome/deb/

Jason Kersey said...

Linux should be OK now.

s.gopal said...

Refer to the sandboxing for flash player in Chrome 10. The chromium blog mentions that sandboxings is available for Windows Vista and above.
Does this mean sandboxing is not available in XP ? Pls clarify

http://www.halffry.com said...

The chrome is the best out of all WB. But the problem is that it does not include "Google toolbar" adding function.
http://www.badbad.co.in

http://www.halffry.com said...

And the pagerank function does not work well.

Piotr said...

Problem Schockwave plugin fail :/
http://img715.imageshack.us/img715/3223/chromedziad.jpg

vhanla said...

This update is unstable, most of the time show all the pages (tabs) blank after some minutes (a popup message appears asking me to close them); on Windows 7 x86. :(

YGTBKsilenceofnoone said...

can the EXTREME lag while typing in the omnibar with instant & webpage pre-rendering on be fixed?

s.gopal said...

Has webGL been disabled in this version ? I am getting the following error - "Your browser does not support WebGL. Try downloading Google Chrome to see the example".

Jia-Jia said...

Chrome Dev for Mac has been slow in every regard except loading a page...if it ever gets to that step. Slow to load, slow to open tab, slow to switch tab, etc. It's not usable for me. Often times, the browser isn't responsive for 30+secs upon launch!!

The same isn't true on Windows. What gives?

LVISS said...

Looks like the issue of changing the font has been fixed. The options page wears a new look .

kecinzer said...

Please fix proxy autodetection.

kfj_stark said...

All my plugins crashes in this release!

Recep said...

i cannot use chrome behind proxy. it freezes :(

Aba said...

This update seems to have broken Jira 4.2.1. I now see erratic behavior when viewing Jira issues on my local install and on Atlassian's web site.