Tuesday, April 27, 2010

Stable Update: Bug and Security Fixes

Google Chrome 4.1.249.1064 has been released to the Stable channel on Windows.

This release fixes the following issues:
  • Google Chrome was not using the correct path for the Java plugin for Java Version 6 Update 20.
  • 4.1.249.1059 was much slower on JavaScript benchmarks than 4.1.249.1045. (Issue 42158)

This release also fixes the following security issues:
Please see the Chromium security page for more detail. Note that the referenced bugs may be kept private until a majority of our users are up to date with the fix.
  • [$1000] [40445] High Cross-origin bypass in Google URL (GURL). Credit: Jordi Chancel.
  • [40487] High Memory corruption in HTML5 Media handling. Credit: David Bloom of Google Security Team.
  • [$500] [42294] High Memory corruption in font handling. Credit: wushi of team509.

If you find issues, please let us know: http://code.google.com/p/chromium/issues/entry

--Mark Larson, Google Chrome Team

23 comments:

Manish said...

Thanks a ton for fixing issue 42158. Gmail has been too slow lately for last 4-5 days. Search for "Gmail slow" keyword in google( Updates option) shows that many people have been facing slow response issue with gmail... Sorry to mention the Gmail stuff in Chrome blog..

Kay S.T. said...

And Linux? :(

steff said...

hmm chrome crashes all the time since this update under windows 7 :(

Heinrich said...

It's all ok here under Windows 7.
No crashes.

steff said...

great, another reason I can hate my computer for >.<

skyhard said...

Come on google, release linux stable already!

Jaimy said...

When do we get chrome for android? Or otherwise bookmark and passwords sync between chrome and the android browser?

Preston said...

I am a Google Apps user. Since upgrading to this latest Chrome release, I can no longer access my calendar or contacts. The only thing I can access is my email. Can you please investigate and tell me how to resolve the issue.

yujue said...

Just upgraded to 4.1.249.1064 several hours ago.
Site favicon didn't show up when URL contains '#' sign; without '#' sign, favicon worked fine.

Ricardo said...

Aqui ta travando num site que entro aqui.Na versao 4.1.249.1045 antes dessa nao acontecia isso. corrijam ae, trava demais.

Fakhri.Me said...

@yujue do you mean it's when you use facebook?

Tan Hwee Tiong said...

Just updated Chrome to 4.1.249.1064 (45376).
Now every time loading up Google Docs, you are met with a narrow thumbnails frame docked right in the middle.
Clicking List View then Thumnail View resolves that.

Firefox 3.6.3 works just fine, so it looks like a glitch in Chrome's latest update.

Running Windows Vista

Kay S.T. said...

Will these secruity bugs be fixed on linux soon?

PorshaCoghlan梁子珠 said...

Thx ur share........................................

Justin said...

has anyone else noticed since maybe chrome 4, that quite often this message comes up "Oops! Google Chrome could not find" comes up a lot sometimes. I love chrome, but this can get really annoying, I never used have this problem so much until recently.

QWP said...

Thanks for the update on Google Chrome.I did use it for awhile but wasn't that satisfied with it.Therefore i uninstalled it.With some changes being done,planning to try it out once again.Thanks.

www.quality-web-programming.com

G.O.S said...

Using 4.1.249.1064 No sight will allow me to login! It just kicks me right back out. Deleted and reinstalled, but still does not work. Checked Cookie settings and everything. It's very odd

karen_w said...

I've had same issues as Justin who posted above the past few days esp.
whats up with Chrome lately ? thx Karen

vurentjie said...

same issue as GOS, the guy sitting next to me is on on version 5 dev and can login on sites i can't things were fine and not anymore since update

vurentjie said...

please note, i uninstalled chrome, re-downloaded the installer from the official site, and now things are dandy again, which means that the update might have corrupted something..or changed a setting that i am not aware of.

Justin said...

hey karen if you go to options and then under the hood... uncheck use dns pre-fetching. it is suppose to help speed up loading pages, however sometimes it seems to do the opposite. anyways since unchecking it, I have not had the problem once. Also ive noticed no speed decrease.

Peter said...

Why doesn't the copyright notice state "copyright 2006-2010", instead of the current "copyright 2006-2009"?

Konrad said...

Hi,
after updating from version 8 (this was running fine) to version 9, the browser crash and even after reinstalling older versions the problem is not soled.
(I can start the browser but opening new windows, he disappeared)

Konrad